Issues with welcome email

Incident Report for AutoFi

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 18:58 PDT

Investigating

We are getting reports of users not receiving the Welcome Emails. The team is investigating.
Posted Mar 11, 2026 - 17:28 PDT
This incident affected: Dealer Apps (Admin Center).