AutoFind AI

Incident Report for AutoFi

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 16:18 PDT

Identified

We're seeing issues with AutoFind AI feature due to a downstream provider outage.
Posted Mar 26, 2026 - 15:36 PDT