CRM integration failures

Incident Report for AutoFi

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 14:20 PDT

Investigating

We are experiencing issues with searching for and importing customers from CRM into Showroom due to an outage affecting a third-party system.
Posted Aug 20, 2026 - 13:25 PDT
This incident affected: Dealer Apps (Showroom).